当前位置:首页>站长教程>火车头>oracle数据库发布提示System.Data.OracleClient 需要Oracle 客户端软件 8.1.7 或更高版本

oracle数据库发布提示System.Data.OracleClient 需要Oracle 客户端软件 8.1.7 或更高版本

使用oracle数据库提示错误:
System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.

解决办法:
尝试用以下方法解决:

一、原来当Oracle 9.2运行在NTFS的分区上时,对于某些非administrator组的用户,ORACLE_HOME 目录是不可见的,而在windows server 2003下asp.net应用使用的帐户是netword service,因此无法创建oracle连接,只要重设一下ORACLE_HOME目录的权限就可以了。步骤如下:
1、以管理员的用户登录;
2、找到ORACLE_HOME文件夹(我的是C:\oracle\ora92),点右键,选属性--安全,在组或用户栏中选“Authenticated Users”,在下面权限列表中把“读取和运行”的权限去掉,再按应用;重新选上“读取和运行”权限,点击应用;选权限框下面的“高级”按钮,确认“Authenticated Users”后面的应用于是“该文件夹、子文件夹及文件”,按确定把权限的更改应用于该文件夹;
3、重新启动计算机,让权限设置生效(请注意,这一步很重要);
4、登录后运行asp.net应用,正常取得Oracle数据库的数据。

二、如果用远程oracle,采集器所在的本地客户端与远程oracle链接时可能需要oracle的相关服务,请在本地安装和远程oracle一样版本的oracle客户端。

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。
火车头

百度文库文档下载

2023-1-8 10:13:14

火车头

循环采集图片标签 与 创建多个标签分别采集图1,图2...

2023-1-8 10:13:16

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索